Invalid External Links & 404 Error Page

Anything relating to this website.
Post Reply
Lie2Me
Members
Posts: 11
Joined: Wed Jun 30, 2010 12:15 am
First Name: Al

Invalid External Links & 404 Error Page

Post by Lie2Me » Thu Jul 01, 2010 9:40 pm

Hi Site Admin (digidog),

I'm posting this in open forum because other people may wish to add comments or info.

I have tried to include a link in my Feedback on brian1947 to the relevant page on the site.

However, TradeMe (or its DB interface code) modifies the link by expanding '&' to '&' which doesn't always seem to work. (Another link from TradeMe with this change does work and I haven't figured out why.)

Anyway, by way of example, this is what TradeMe did:

http://scambusters.co.nz/forum/viewtopi ... 35&start=0

with this original URL:

http://scambusters.co.nz/forum/viewtopi ... 35&start=0

but the modified URL doesn't work because of the change.

Hence my question: Is it possible to modify the site so that these URLs get correctly interpreted?

Alternatively, if that's not possible or easy to do, would it be possible to describe this situation and what to do about it on the 404 Error page, so that people who try to follow corrupted TM links don't just assume the page has been removed and give up?

Ok, I have now figured this out. It depends which '&' gets amended, and the TM site is not consistent. If it's the 1st one, the link doesn't work. If it's the 2nd one, it does!

BYW & FWIW, I read the TM Feedback Rules before I amended my Feedback, and there's nothing mentioned about posting links to other discussions in your feedback (Not YET, anyway).

L2M

User avatar
digidog
Site Admin
Posts: 15014
Joined: Wed May 05, 2004 2:25 am
First Name: Alfie
Location: Otago
Contact:

Post by digidog » Fri Jul 02, 2010 1:33 am

Hi L2M... I'm not sure why there's a difference between the two URLs and
I doubt that TM is modifying them. Our technical man Scott may be able to
shed some light on this.

User avatar
EzyAuctioNZ
Members
Posts: 358
Joined: Sat Sep 23, 2006 9:02 am
First Name: Scott
Location: Auckland
Contact:

Re: Invalid External Links & 404 Error Page

Post by EzyAuctioNZ » Fri Jul 02, 2010 1:43 am

& and & are actually the same literal character, & is the proper one for encoding into URL's and for xml or xhtml compliance.

However, when & is seen some systems try to convert it to & (to turn a normal & into an &) this can break URL's.

I will have to look into this further to see what exactly is happening in this situation.
Cheers

Scott
http://www.ezyauctionz.co.nz

User avatar
EzyAuctioNZ
Members
Posts: 358
Joined: Sat Sep 23, 2006 9:02 am
First Name: Scott
Location: Auckland
Contact:

Re: Invalid External Links & 404 Error Page

Post by EzyAuctioNZ » Fri Jul 02, 2010 1:47 am

The easiest way of fixing this is probably to add a "REPLACE" to the htaccess file, to replace any occurances of & with & in any urls, there would not be any downside to doing this.
Cheers

Scott
http://www.ezyauctionz.co.nz

Lie2Me
Members
Posts: 11
Joined: Wed Jun 30, 2010 12:15 am
First Name: Al

Re: Invalid External Links & 404 Error Page

Post by Lie2Me » Fri Jul 02, 2010 2:21 am

Hi Guys,

Sounds all good to me.

(Yes, I'm pretty sure the TradeMe site engine is doing the mod, because it sure wasn't me!)

Is it also possible to put a message on the 404 Error Page as well, to try to catch / help all comers?

Cheers,
L2M

Lie2Me
Members
Posts: 11
Joined: Wed Jun 30, 2010 12:15 am
First Name: Al

Re: Invalid External Links & 404 Error Page

Post by Lie2Me » Mon Jul 05, 2010 10:37 am

Hi Scott,

I now see there are two possible invalid URL results.

One is a genuine 404 Error page (could you add to that and suggest people remove extra spaces from the address), and the other is (I guess) a Database "Miss" page, which you can see by adding a couple of digits to the &t=value. Says the following:
Information

The requested topic does not exist.
Any chance that message could also be augmented to suggest they try removing extra spaces and maybe change & to &?

Cheers,
L2M

Post Reply

Who is online

Users browsing this forum: Bing [Bot] and 1 guest